Exercise 1a: Interacting With HyperMesh

This exercise will cover many of the basic concepts that are central to many of the features in HyperMesh. By the end of this exercise you should be familiar with the basic features of the HyperMesh software.

Step 1: Set the User Profile and retrieve the model file, 01-GUI.hm

1. From the menu bar, select Preferences > User Profiles or select the icon.
2. Select the OPTISTRUCT user profile and from the drop down menu.
3. Click OK.
4. Select File > Open > Model from the menu bar or select the icon.
5. Select the file 01a-GUI.hm.
6. Click Open.

Step 2: Rotate, Pan and Zoom the model

1. Hold down the CTRL key.
2. Click the LEFT Mouse button. (Note the small square in the center of the screen indicating the rotational center).
3. While holding both the CTRL Key and LEFT Mouse Button, drag your mouse around to rotate the model.
4. Click near a node (Note the small square moves to the node selected and becomes the new center of rotation). Continue to rotate the model.
5. While holding the CTRL Key and the RIGHT Mouse Button, drag your mouse around to pan the model.
6. While holding the CTRL Key, click the Center Mouse Button (or clickable scroll wheel) and draw a circle around a portion of the screen.
Chapter 1: Basics HyperMesh Desktop

7. This will zoom into the region surrounded by the drawn circle.

8. While holding the CTRL Key rotate the scroll wheel forward to Zoom Out and backward to Zoom In.

9. While holding the CTRL Key click the middle mouse button/scroll wheel to “fit” the model to the screen.

Step 3: Use the Model Browser to control visualization

1. Press F on the keyboard to “fit” the model to the screen. If it does not work, click in the graphics window and then press F.

2. Make sure the Model Browser tab is active.

3. Expand the Components category by clicking the + next to it. This will list all of the components in the model.

4. Using the Geometry and Elements Icons, turn on and off components.
5. Using the **Show/Hide Button** turn off and on components in the graphics window. Right click to hide a component and left click in the area of a hidden component to see a ghost image of the hidden component. Releasing the button reveals the component.

6. Using the **Isolate Button**, right click on a component in the graphics window to isolate it (turn off all other components) and left click on a hidden component to see a ghost image of the hidden component. Releasing the button isolates the selected component.

7. Use the global controls to turn on, off and reverse all of the components.

8. Highlight components using the Left Mouse Button in the Graphics Area, and note how the Global Controls now only affect the highlighted components.

9. Use the icon to switch the global controls between the Geometry, Elements and Both options.

10. Review the other **Model Browser Views**:

   a. **Component View**

      This view is highly useful when working solely with components as none of the other collectors are shown in the view. This view contains all of the visibility control and right click functions of the **Model View**. Additionally it adds fields that show the mesh and geometry shading as well as the property and material applied to each component.

      Currently there aren’t any material or properties assigned, but expand the browser area to see what is available in this view.
b. **Property View**

This view allows the user to view all of the properties in the model and color the entities on the screen by their assigned property. The visibility controls as well as all right click extended functionality work with this view as well.

<table>
<thead>
<tr>
<th>Entities</th>
<th>ID</th>
<th>Type</th>
<th>CardImage</th>
<th>Material</th>
<th>Thickness</th>
<th>MID</th>
<th>Material Type</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>2D</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Skin_PCOMPP</td>
<td>102</td>
<td>2D</td>
<td>PCOMPP</td>
<td>0.000000000000000</td>
</tr>
<tr>
<td></td>
<td>2D</td>
<td>2D</td>
<td>PSHELL</td>
<td>Aluminum</td>
<td>3.000000000000000</td>
<td>2134004000000000</td>
<td></td>
</tr>
<tr>
<td></td>
<td>11.5</td>
<td>2D</td>
<td>PSHELL</td>
<td>Aluminum</td>
<td>1.500000000000000</td>
<td>2134004000000000</td>
<td></td>
</tr>
<tr>
<td></td>
<td>10.0</td>
<td>2D</td>
<td>PSHELL</td>
<td>Aluminum</td>
<td>10.000000000000000</td>
<td>2134004000000000</td>
<td></td>
</tr>
<tr>
<td></td>
<td>12.0</td>
<td>2D</td>
<td>PSHELL</td>
<td>Aluminum</td>
<td>2.000000000000000</td>
<td>2134004000000000</td>
<td></td>
</tr>
<tr>
<td></td>
<td>12.5</td>
<td>2D</td>
<td>PSHELL</td>
<td>Aluminum</td>
<td>2.500000000000000</td>
<td>2134004000000000</td>
<td></td>
</tr>
<tr>
<td></td>
<td>13.0</td>
<td>2D</td>
<td>PSHELL</td>
<td>Aluminum</td>
<td>3.000000000000000</td>
<td>2134004000000000</td>
<td></td>
</tr>
<tr>
<td></td>
<td>13.5</td>
<td>2D</td>
<td>PSHELL</td>
<td>Aluminum</td>
<td>3.500000000000000</td>
<td>2134004000000000</td>
<td></td>
</tr>
<tr>
<td></td>
<td>14.0</td>
<td>2D</td>
<td>PSHELL</td>
<td>Aluminum</td>
<td>4.000000000000000</td>
<td>2134004000000000</td>
<td></td>
</tr>
<tr>
<td></td>
<td>14.5</td>
<td>2D</td>
<td>PSHELL</td>
<td>Aluminum</td>
<td>4.500000000000000</td>
<td>2134004000000000</td>
<td></td>
</tr>
<tr>
<td></td>
<td>15.0</td>
<td>2D</td>
<td>PSHELL</td>
<td>Aluminum</td>
<td>5.000000000000000</td>
<td>2134004000000000</td>
<td></td>
</tr>
<tr>
<td></td>
<td>16.0</td>
<td>2D</td>
<td>PSHELL</td>
<td>Aluminum</td>
<td>6.000000000000000</td>
<td>2134004000000000</td>
<td></td>
</tr>
<tr>
<td></td>
<td>17.5</td>
<td>2D</td>
<td>PSHELL</td>
<td>Aluminum</td>
<td>7.000000000000000</td>
<td>2134004000000000</td>
<td></td>
</tr>
<tr>
<td></td>
<td>18.0</td>
<td>2D</td>
<td>PSHELL</td>
<td>Aluminum</td>
<td>8.000000000000000</td>
<td>2134004000000000</td>
<td></td>
</tr>
<tr>
<td></td>
<td>18.0_offset.5</td>
<td>2D</td>
<td>PSHELL</td>
<td>Aluminum</td>
<td>8.000000000000000</td>
<td>2134004000000000</td>
<td></td>
</tr>
<tr>
<td></td>
<td>16.0_offset.5</td>
<td>2D</td>
<td>PSHELL</td>
<td>Aluminum</td>
<td>3.000000000000000</td>
<td>2134004000000000</td>
<td></td>
</tr>
<tr>
<td></td>
<td>15.0_offset.5</td>
<td>2D</td>
<td>PSHELL</td>
<td>Aluminum</td>
<td>5.000000000000000</td>
<td>2134004000000000</td>
<td></td>
</tr>
</tbody>
</table>


c. **Material View**

This view allows the user to view all of the materials in the model and color the entities on the screen by their assigned material. The visibility controls as well as all right click extended functionality work with this view as well.
11. Return to the Model View and use the right click Extended Menu to try the following functions:
   a. Create a new component
   b. Rename a component
   c. Delete a component
   d. Show/Hide a component
   e. Isolate a component
   f. Isolate Only a component (see if you can figure out the difference between Isolate and Isolate Only)
   g. Right click on a color and change the color of a component.

**Step 4: Working with Collectors**

1. Right click in the Model Browser and select Create > Component.
2. Name it Fuselage.
3. In the Entity Editor, select a color.
   The new collector has been created and now we will move the elements for the fuselage exterior skin into this new collector.
4. From the menu bar select Mesh > Organize > Elements > To Component or select the icon .
5. In the Model Browser click the Selector Icon . This allows you to pick components from the graphics window.
6. Click the fuselage skin (blue) in the graphics window.
7. Click the **Add To Panel Collector** icon. This will add the selected components to the selection.

8. Click the **dest component** button and select the newly created **Fuselage** component.

9. Click **move** and the elements in the collector will be moved to the new component.

10. Click **return** to exit the panel.

**Step 5: Use of Panels and Directional Functions**

This step will introduce the user to commonly used functions in panels as well as the use of the directional definition tools found in many HyperMesh panels.

1. Locate the item in the menu bar that allows you to Translate Elements (**Mesh > Translate > Elements**).

2. Select the component **Rib 6**. *Hint: Step 4.5-4.7 above.

3. From the direction definition switch select **N1, N2, N3**.

X, Y and Z axis will translate along those cardinal axis, while N1,N2,N3 allows the user to define a direction as a vector (N1->N2) or as a normal to a plane defined by the points N1,N2 and N3 following the right hand rule.

4. Pick a node on the flat face of the **Rib 6** component shown below. A green dot will appear at the selected node showing that N1 has been defined there. The blue focus square will automatically move to N2.
5. Continue in a Clockwise direction picking two more nodes on the face defining the blue N2 and red N3 nodes. Your model should look similar to the picture above. NOTE: It is not necessary that your nodes be identical to the image, just similar.

6. Enter 30 in the magnitude= field.

7. Click translate +.

   The entire component will move 30 model units in the positive direction defined by the normal of the plane N1, N2 and N3.

8. Click reject.

9. Try moving the component in other directions using both cardinal axis and the N1, N2 and N3 options.

10. Try moving the component using only N1 and N2 and then change the magnitude= field to N2-N1 and see what that option does.

11. Use the reject button and the opposite direction translation to bring your component back to the previous location.

12. Click return to exit the panel.
Step 6: Using the Mask Function and Selecting Entities

1. Using the Mask Icon enter the Mask panel.
2. Change the entity selection to elems.
3. Pick a number of elements on the screen.
4. Click mask.
   This will hide the elements from view but they still can be affected through other panels
5. Click the Reverse Icon.
   This will Unmask the hidden elements and will mask all the elements previously shown.
6. Click the Unmask Adjacent Icon.
   This will Unmask elements immediately adjacent to those on the screen. This can be done repeatedly
7. Click the Unmask All Icon to bring everything into view.
8. Click the Mask Icon again
9. Hold the Shift Key down and holding the Left Mouse Button, drag a box in the graphics window to box select elements.
10. Hold the Shift Key down and holding the Right Mouse Button, drag a box in the graphics window to de-select elements.
11. Click the yellow elems button to open the extended selection window.

<table>
<thead>
<tr>
<th>by/window</th>
<th>on plane</th>
<th>by width</th>
<th>by/geom</th>
<th>by domains</th>
<th>by path</th>
</tr>
</thead>
<tbody>
<tr>
<td>displayed</td>
<td>retrieve</td>
<td>by group</td>
<td>by/adjacent</td>
<td>by/attached</td>
<td>by/block</td>
</tr>
<tr>
<td>all</td>
<td>by id</td>
<td>by config</td>
<td>by/faces</td>
<td>by/ply</td>
<td></td>
</tr>
<tr>
<td>reverse</td>
<td>by assos</td>
<td>by sets</td>
<td>by/outputblock</td>
<td>by/eliminate</td>
<td></td>
</tr>
<tr>
<td>by collector</td>
<td>by assos</td>
<td>by sets</td>
<td>by/outputblock</td>
<td>by/eliminate</td>
<td></td>
</tr>
</tbody>
</table>

12. Experiment with options, including the following;
   - displayed – Selects entities currently displayed on the screen
   - all – Selects ALL entities in the model, displayed or not.
   - reverse – After selecting a few elements this will “reverse” the selection.
   - by collector – Displays a list of collectors and entities can be selected by the collector they are in.
   - by geom – By choosing either surfs or solids, elements can be selected by picking the geometry that they were created from. Useful in that a single geometry selection can select many elements.
- **save/retrieve** – Saving a selection places those entities into a 1 slot “user mark” that can be retrieved again and again in selections until it is overwritten.

13. Click **return** to exit the panel.

14. From the menu bar; **File > New > Model** to clear out the model.