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Exercise 10a - Creation of an Aircraft Door Surround Composite 
Skin Model for OptiStruct and NASTRAN 

Step 1: Start HyperMesh in the OptiStruct user profile and open the 
HyperMesh model file 
1. Start HyperMesh 

2. Select the OptiStruct user profile 

3. Open the HyperMesh model file, 10a_Composite_Skin.hm 

This model contains a mesh of the aircraft door surround composite skin within the 
component Skin.  A .CATPart file containing CPD data for 140 plies which make up the 
composite skin of the door surround was also previously imported.  This import process 
produced 140 plies with related ply data and ply shape (contained within the component 
Ply_shapes), 1 laminate containing the stacking sequence, 1 material reference, and 1 
coordinate system defining the ply fiber direction. 

Step 2: Assign element normals and element material orientations 
1. Review the current element normals.  From the menu bar select Mesh > Assign > 

Element Normals.   
2. With the component collector active, select the Skin component by clicking any element 

of the skin component in the graphics window, and then click display normals.   
 

3. Notice that the element normals are pointing “outward” from the fuselage skin.  Typically 
we desire the element normals to point “inward”.  Since the staking direction of the plies 
is in the direction of the element normals, and if this points “inward”, then we can define 
the laminate in such a way that the outer mould line (OML) of the fuselage skin remains 
“smooth” and that all ply drops will occur in the inner mould line (IML). 
 

4. Reverse the element normals so that element normals point “inward”.  With the 
component collector active, select the Skin component again to ensure it is selected, 
and then click reverse normals.  Now the element normals are pointing “inward”.   

5. Click return to exit the panel. 
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6. Review the current element material orientations.  From the menu bar select Mesh > 
Assign > Element Material Orientation.   

7. With the element collector active, select elems >> all, and then select review.   

8. Zoom in on the mesh and notice that the element material orientations are in all different 
directions.  (You may need to change the element view to wireframe to view the 
orientations).  The element material orientation defines the 0o direction for a ply.  In this 
case, we desire the 0o direction for a ply to be along the length of the fuselage.  
Therefore, we need to reassign the element material orientations to be consistent and in 
this direction. 

9. With the element collector active, select elems >> all again.   

10. Select the by system axis material orientation method.   

11. With the system collector active, select system 1 located at the lower left hand corner of 
the door surround skin.   

12. Select the local 1-axis option, and then click project.   
13. Zoom in on the mesh and notice that all element material orientations are now defined 

along the length of the fuselage as we desired, thus defining the 0o ply direction.   

14. Click return to exit the panel. 
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Step 3: Edit Carbon material and create a new FiberGlass material 
1. From the Model Browser; expand the Material folder and select Carbon.   

2. Click on Carbon and update the Card image to MAT8 in the entity editor. 

 
3. Next we will define orthotropic material properties for the Carbon material. Enter the 

following orthotropic properties for the Carbon material in the entity editor. 
E1 = 2.2e7 
E2 = 1.3e6 
NU12 = 0.3 
G12 = 7.5e5 
RHO = 0.056  

 
 

4. Create a new FiberGlass material with MAT8 orthotropic material properties by right 
clicking in the menu bar and selecting Materials > Create.   

5. On the Create Material dialog, enter the Name as FiberGlass, set the Card image 
as MAT8, then enter the following orthotropic properties for the FiberGlass material and 
then click close 

E1 = 7e6 
E2 = 2e6 
NU12 = 0.25 
G12 = 1e6 
RHO = 0.065 
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Step 4: Realize geometric ply shapes to FE ply shapes 
On import of ply information from a CAD file, the ply shape definitions are defined with geometric 
lines.  In order to create an FE model suitable for analysis, we must convert the geometry ply shapes 
to FE ply shapes.  This process is called ply realization.  First let’s review the geometry ply shape 
definition for a ply.   

1. First we will review the geometric ply shapes.  Using the Model Browser, turn off the FE 
display  of the component Skin and turn on the Geometry display  of the 
component Ply_shapes.   

2. Within the Model Browser, expand the Ply folder and select Plies Group.1_PLY-30.   

3. Right click on the selection and select Edit.  This will bring up the Edit Ply dialog and 
highlight the geometric shape (lines) of the ply in the graphics area for review. 

4. Select Cancel to close the dialog. 
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5. Next we will realize the geometric ply shapes to FE ply shapes.  Using the Model 
Browser, turn on the FE display  of the component Skin.   

6. From the Model Browser; select the Ply folder.   

7. Selecting any folder implicitly selects all entities within that folder. Right click on the Ply 
folder and select Realize.   

8. Click on Component and then select the Skin component by clicking any element of the 
skin component in the graphics window.  Select proceed.  

9. Select the Project Normal to target mesh for CPD/Geom data as the projection 
option, and then click Realize.   

10. All 140 plies will have their geometric shape definition converted to an equivalent FE 
shape definition by identifying all elements within the boundaries of the closed loop lines 
which define the geometric shape of each ply. 

11. Next we will review the FE ply shapes.  From the Model Browser, select Plies 
Group.1_PLY-30. Right click on the selection and select Edit.  This will bring up the Ply 
edit dialog and highlight the FE shape (elements) of the ply in the graphics area for 
review. 

12. Select Cancel to close the dialog. 
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Step 5: Create two OML FiberGlass protection plies 
13. First we will create a 45o FiberGlass ply.  From the menu bar select Properties > Create 

> Plies.   

14. On the Create ply dialog, enter the following ply data: 
Name: OML Group.1_PLY-1 
Material type: ORTHOTROPIC 
Material: FiberGlass 
Thickness: 0.0078 
Orientation: 45 

 

15. Define the FE Shape of the 45o FiberGlass ply by clicking on Element and then 
selecting elems>>all.  Then select proceed.   

16. Click Create to create the ply. 
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17. Now create a -45o FiberGlass Ply.  Repeat steps 5.1-5.4 above with Name as OML 
Group.1_PLY-2 and an orientation of -45o.  Close out of the Create Ply dialog when 
complete. 

Step 6: Edit the laminate stacking sequence definition to insert the OML 
FiberGlass protection plies to the OML. 
1. Review the current laminate stacking sequence.  From the Model Browser, expand the 

Laminate folder and select Stack.   

2. Right click on the selection and select Edit.  This will bring up the Edit Laminate dialog 
showing the current stacking sequence of plies for the door surround skin. 

3. For the Card Image, select STACK. 

4. For the Laminate option, select Total. 
5. Edit the laminate stacking sequence by inserting the OML FiberGlass protection plies to 

the “top” of the stack so that they are on the OML of the door surround skin.  Click on the 
1st column of the 1st row to highlight the first row.   

6. Right click on the selection and select Insert.  This will insert a blank row at the “top” of 
the stack.   

7. Do these steps again to insert a second black row at the “top” of the stack.   

8. Click in the Name column (2nd column) of the first row and select OML Group.1_PLY-
1 to insert this ply into the stack at this location.   

9. Click in the Name column (2nd column) of the second row and select OML 
Group.1_PLY-2 to insert this ply into the stack at this location.  The final stacking 
sequence is shown below.   

10. Click Update to commit the changes to the HyperMesh database and exit the Edit 
Laminate dialog. 
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Step 7: Create and Assign a ply-based template property to all elements 
1. Next we will create a ply-based template property (PCOMPP) with Z0 = 0.0.  From the 

menu bar select Properties > Create > Properties.  

2. Define the Name as template_property .   

3. For the Card image select PCOMPP.   

4. Make sure to check Card edit property upon creation and then click Create.  

5. On the PCOMPP card image, click on Z0 and enter 0.0.   

This defines the node plane of the mesh as the OML surface (i.e. bottom of the laminate) 
and since the element normals are pointing “inward” and the laminate plies stack in the 
direction of the laminate normal, all ply drops will be toward the IML surface and the 
OML surface will remain “smooth”. 
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6. Select return. 

7. Now we will assign the ply-based template property to all the elements.  From the Model 
Browser, expand the Property folder and select template_property.   

8. Right click on the selection and select Assign.   

9. This will bring up an elements collector panel.  With the elements collector active, select 
elems>>all and then click proceed.   

This assigns all elements the template_property and alerts OptiStruct to calculate each 
elements laminate from the PLY and STACK card image information defined within the 
model. 

Step 8: Review the composite skin definition using 3D Representation with 
Composite Layers visualization 
1. Set the visualization settings to review the model.  From the Visualization toolbar select 

the By Prop color mode, set Shaded Elements and Feature Lines , set 3D Element 
Representation , and set Composite Layers  as shown below. 
 

 
 

2. Now we will set the ply visualization thickness factor.  From the menu bar select 
Preference > Graphics.   

3. Set the ply visualization thickness factor to 8.   

This will artificially increase the thickness of the plies 8x to allow for visualization of the 
composite skin definition while also maintaining visualization capabilities of the extents 
of the part. 
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4. Review the composite skin definition by translating, rotating, and zooming the part as 
required/necessary. 
 

 
 

5. Set the visualization settings to work on the model again.  From the Visualization 
toolbar, set Shaded Elements with Mesh Lines , set Traditional Element 
Representation , and set Layers Off  as shown below. 
 

 

Step 9: Create boundary conditions; constraints and loads 
1. Create a load collector to “hold” the constraint definition.  From the menu bar, select 

Collectors > Create > Load Collectors.  

2. Enter the Name as Constraint, set the Card image as none, set the color as Blue, 
and click Close.  Note that this operation makes Constraint the current collector.  Any 
created boundary condition automatically gets organized into the current collector. 

3. Now we will create simple support constraints (SPC) on all edges of the door surround 
composite skin.  From the menu bar select BCs > Create > Constraints.   

4. With the nodes collector active, click on the nodes >> by path and then select each 
corner node of the door surround composite skin in clockwise fashion. 
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5. Check dof1 (x-translation), dof2 (y-translation), and dof3 (z-translation); and uncheck 
dof4 (x-rotation), dof5 (y-rotation), and dof6 (z-rotation). 

 
6. Set the load types as SPC.  Click create to create the simple support constraint.   

7. Click return to exit the panel. 

8. From the menu bar select Collectors > Create > Load Collector.   
9. Define the Name as Pressure, set the Card image as none, set the color as Red, and 

click Close.  Note that this operation makes Pressure the current collector.  Any created 
boundary condition automatically gets organized into the current collector. 

10. Create a constraint pressure (PLOAD4 = 10 psi) on the IML side of the door surround 
composite skin applied outward toward the OML.  From the menu bar, select BCs > 
Create > Pressures 

11. With the element collector active, select elems>>all.   
12. Enter the magnitude as -10.0, since the element normals are pointing “inward” and we 

want the pressure to be applied “outward”.   

13. Set the direction as normal.   
14. Set the load types as PLOAD4.   

15. Click create to create the pressure loads.   

16. Click return to exit the panel.  
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Step 10: Create load steps and control cards 
1. Next we will create a pressure loadstep (subcase).  From the menu bar select Tools > 

Load Step Browser.   
2. Within the Load Step Browser right click in the white space and select New Loadstep.   

3. Define the Loadstep name as Pressure_LC and click Create. 

4. Click on the Loadstep Type tab and select Linear static for the loadstep type. 

5. Click on the Headers tab and do nothing.  You can optionally define loadstep (subcase) 
title/subtitle/etc. information on this tab. 

6. Click on the Load References tab and then click SPC to define the SPC definition for 
this linear static loadstep (subcase).  The Available SPC constraints table lists the 
available SPC constraints that can be defined for this linear loadstep (subcase).  

7. Select Constraints and then select the arrow pointing to the right to add it to the 
Selected SPC constraints table. 
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8. Remaining on the Load References tab, click LOAD to define the applied load definition 
for this linear static loadstep (subcase).   

9. The Available applied loads table lists the available applied loads which can be 
defined for this linear static loadstep (subcase).  Select Pressure and add it to the 
Selected applied loads table by click the right arrow button. 

 
10. Click on the Output Requests tab, and do nothing.  You can optionally define loadstep 

(subcase) dependent output requests on this tab. However, we will define global output 
requests in the next step for this particular model setup. 

11. Click OK to finish defining the loadstep (subcase) and exit the wizard.  You will notice 
that the loadstep definition now exists in the tree structure of the Loadstep Browser. 

12. Now we are going to define the global output requests.  From the Loadstep Browser, 
right click on Global Options and select Edit Options to display the Loadsteps Global 
Options dialog.   
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13. Select the Output Requests tab, then select CSTRAIN and check Output to obtain ply-
level strain for plies with results. 

14. Select CSTRESS and check Output to obtain ply-level stress for plies with results. 

15. Select DISPLACMENT and check Output to obtain nodal displacements. 

16. Select STRESS and check Output.  In addition, scroll to the right and set OPTION to 
NO so that homogeneous shell stresses are not output. 
 

 
 

17. Next we will define the output file format.  Remaining on the Loadsteps Global Options 
dialog, click the Output Formats tab.   

18. Select H3D and check Output to obtain results in the .h3d file format.   

19. Click OK to finish defining the loadstep global options and exit the dialog.  You will notice 
that the loadstep global options now exist in the tree structure of the Loadstep Browser. 
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Step 11: Save, Export, and Solve the ply-based model in OptiStruct 
1. From the menu bar, select File > Save as > Model.   
2. In the Save Model as dialog, save the model as 

9a_Door_Surround_Composite_Skin_PLY.hm. 

3. From the panels area, select the Analysis page and enter the OptiStruct panel.   

4. Keep all entries as default, and enter –optskip in the options field as shown below. 

 
5. Click OptiStruct to export the model deck and submit to the OptiStruct solver 

automatically from within HyperMesh.   

6. Once the run is completed, click return to exit the panel. 

Step 12: Post-process the ply-based model 
1. Add a page 2 to the session for post-processing the model.  From the Page Controls 

toolbar; click the Add Page  button to add a page 2 to the session.  By default the 
new page single window client will be a HyperView client. 
 

 
 

2. Open the model and results files for post-processing within HyperView.  From the menu 
bar select File > Open > Model.   
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3. Within the panel, select the 10_Door_Surround_Composite_Skin_PLY.h3d file for 
both Load model and Load results and click Apply.  The model and results get loaded 
into HyperView for post-processing. 

4. From the Results toolbar, click Contour  to open the Contour panel.   

5. Within the Contour panel set the Result type as Displacement (v) and the component 
to Mag and click Apply.  This contour plots the nodal displacements. 

 
 

 
 

Step 13: Realize the ply-based model as a zone-based mode 
1. Switch back to page 1 where the HyperMesh client exists in window 1.  From the page 

controls toolbar; click the Previous Page  button to switch back to page 1. 
 

 
2. Realize the ply-based model into a zone-based model.  Make sure the By Prop color 

mode is activated on the Visualization toolbar. 

 
 

3. From the Model Browser, expand both the Laminate and Property folders and select 
the Stack laminate.   
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4. Right  click on the selection and select Realize.  This operation will convert the ply-
based model defined by PLY/STACK into a zone-based model defined by PCOMP/G.  
You should notice 19 additional properties (PCOMP/G) get generated and assigned to 
the proper elements as you can visualize from the color coding of the model in By 
Property color mode shown below. 
 

 
 

5. Edit the zone-based property to review the PCOMP/G definitions.  From the Model 
Browser, select prop_lam1_13 from the Property folder.   

6. Right click on the selection and select Card Edit.  This will bring up the PCOMP/G card 
image for the prop_lam1_13 property.  Notice that this definition is equivalent to the ply-
based form and that it retains the ply Ids for each ply.   

7. Click return to exit the card image dialog. 

Step 14: Save, Export, and Solve the zone-based model in OptiStruct 
1. From the menu bar, select File > Save as > Model.   
2. In the Save Model as dialog, save the model as 

10_Door_Surround_Composite_Skin_ZONE.hm. 

3. From the panels area, select the Analysis page and then the OptiStruct panel.  

4. Keep all entries as default, and enter –optskip in the options field.   

5. Click OptiStruct to export the model deck and submit to the OptiStruct solver 
automatically from within HyperMesh.   

6. Once the run is completed, click return to exit the panel. 

Step 15: Post-process the zone-based model 

1. From the Page Controls toolbar, click the Next Page  button to switch back to page 
2. 
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2. From the Page Controls toolbar; click the Page Window Layout  button and select a 

two window layout, . 

3. Click inside the currently empty page 2 window 2 to make it the active client (blue halo 
around the window frame).  From the Menu bar, select File > Open > Model. 

4. Within the panel, select the 10_Door_Surround_Composite_Skin_ZONE.h3d file 
for both Load model and Load results and click Apply.  The model and results get 
loaded into HyperView for post-processing. 

5. From the Page Controls toolbar, click the Synchronize Windows  button, make 
sure both windows are “blue” and click OK.  This operation synchronizes the display 
for both widows.  Whatever display manipulation you make in one window will 
automatically be applied to the other window.  Try it out by translating, rotating, zooming 
the model in one of the windows.  Both models move together! 

6. Click inside page 2 window 2 to make it the active client (blue halo around the window 

frame).  From the Results toolbar, click Contour  to open the Contour panel.   

Within the Contour panel set the Result type as Displacement (v) and the component 
as Mag and click Apply.  This contour plots the nodal displacements. 
 

 
 
Notice that the displacement results between the ply-based and zone-based models are 
identical.  Thus we can conclude that the ply-based realization into a zone-based model 
was accurately performed! 
 

 


